Dave Chapman

Optimized file cannot be opened

10 posts in this topic

I have update to 5.7 on Mac

Optimize works ok but the fill cannot be opened, message indicates 'it may be damaged or use a file format that Preview doesn't

recognise  

Any ideas how to correct this

Share this post


Link to post
Share on other sites

Hi Dave,

 

I am sorry to know the issue. In order to help us better figure it out, please attach both of your PDF files before and after optimizing here to send to me for further analysis. And please confirm which DPI option did you choose to optimize? With more details, we will try the best to help you solve it.

 

Thanks.

 

Share this post


Link to post
Share on other sites

Optimize produces a tiny, mostly blank PDF file for me.  Using v5.7.  I'll see if I can upload an example here.  Unfortunately, the 2-page PDF file keeps growing as I add form fields and is now 1.3Mb in size!  It doesn't matter what optimize setting I choose, it's the same size file output and lack of content.

 

Lots of other issues with form creation too - the tick boxes seem to default to show the ticks regardless of the option settings.

Test_Memform-2016.pdf

Test_Memform-2016_Optimize.pdf

Capto_Capture 2017-01-24_05-38-44_pm2.png

Share this post


Link to post
Share on other sites

Hi Ruyton,

 

i am sorry for the issues. Could you please try to open the optimized file by Adobe Reader to check whether it can be opened normally. And please also try to use some different DPI options to oprimize, then check whether the new optimized files can be opened by Preview when you use different DPI.

 

How did you create the check boxes? Did you copy and paste to duplicate them or did you create them one by one? Please confirm more steps that you took.

 

Thanks

Share this post


Link to post
Share on other sites

I don't have Adobe reader on the iMac, but when I open the PDF Element optimized file on a PC using Adobe Reader, I see the the form input boxes but none of the original PDF document.  The text input and dropdown list seem to work, but some of the tick boxes work and others are unresponsive..

 

I optimised the original document using PDFOptim Light at Quartz 144 Medium quality and I get a 94% optimization (1.4Mb to 0.08Mb) and I get a good result - apart from the random tick boxes.  Trying to use 'Image Filter' optimization at any quality in PDFOptim it says 'Already Optimized'

 

I Created some of the check boxes individually, but then I copied and pasted to get the others.  I did suspect that the copy/paste was a problem and found that if you don't change the Name of each box, then they all act as one - tick one and they are all ticked.

 

I deleted all the check boxes and recreated them individually but still had issues but I will try this again.

 

 

Test_Memform-2016_PDFOptim.pdf

Share this post


Link to post
Share on other sites

OK tried again form scratch:

 

- Original document created in Mac Pages

- Exported as a PDF file

- Loaded into PDF Element, all looks good.

- Optimized in PDF Element, preview works at all DPI options and optimized PDF file saves OK

 

The problem seems to be with forms:

 

- Loaded original non-optimized PDF file into PDF Element

- Selected 'Form' and created a single text input box

- Renamed the text input box to 'Callsign'

- Attempted to optimize the document and got the error '.......... could not be opened' see attached screenshot.

- Saved the PDF file anyway and tried to open it in Mac Preview and got the same error message plus '... may be damaged or use a file format that the Preview doesn't recognise.

- Tried to open the same file on the PC using Adobe Reader and ger a blank document plus a warn 'There was a problem reading this document (14)'

 

Definitely something to do with adding the form boxes I think?

Capto_Capture 2017-01-25_09-21-24_am.png

Capto_Capture 2017-01-25_09-22-02_am.png

Share this post


Link to post
Share on other sites

New blank document created using PDF Element

 

- A single form text field added and renamed as 'Callsign'

- Document saved

- Attempted to optimize and use 'Preview' in the PDF Element optimize window and get the 'damaged' error - see attached screenshot.

 

So, this is a blank document created with PDF Element with ONLY the renamed text field on the page.

Capto_Capture 2017-01-25_09-41-11_am.png

Share this post


Link to post
Share on other sites

Hi Ruyton,

 

I am sorry for the optimized issue, I have already forwarded it to our programmers for further analysis and we will try the best to solve it.

In case you need the optimized file urgently, I have used our windows version program to help you optimize the PDF file, so you can download the new optimized PDF file from the attachment to check whether it can meet your needs.

 

Thanks

Test_Memform-2016_PDFOptim_optimize.pdf

Share this post


Link to post
Share on other sites

Many thanks, the form is still in 'beta' at the moment due to the issue with the check boxes.  They are all set to be unchecked in PDF Element, but as you can see, some of them come out checked.

Share this post


Link to post
Share on other sites

Hi Ruyton,

 

Do you mean the new PDF file that was optimized by the windows version program also has the issue? However, I have opened the optimized PDF file in both of our windows version program and Adobe program, there is no box checked actually. So could you please confirm whether the new PDF file that was optimized by the windows version is ok? If it is not ok, please make a screenshot to show me the issue you get.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now