PDFElements Does Not Run in iPhone

2 posts in this topic

Sorry for posting this here.  I could not find a Tech Support section.  I read the great reviews on PDFElements, so I downloaded it from the App Store to my iPhone X.  After running the app, it asked if I wanted to   create a Wondershare account which I did and I authenticated.  When I clicked on the app for the first time, it opened up and hung there for approximately 10 seconds then suddenly closed.  There was a white box in the middle of the screen with a blue striped shape inside the white box. The app was unresponsive during this 10 second span.


I tried clicking on this app a few more times with the same results.  Then I thought maybe there was a problem with the install.  After uninstalling the app, I reinstalled it through the App Store.  Unfortunately I received the same issues.


Lastly, I uninstalled the app then I rebooted my phone.  I again installed the app again. I still get the same issues.


Does anyone have suggestions?  Maybe this should be handled by the Wondershare Tech Support?





Share this post

Link to post
Share on other sites

Hi Jeff,


I am sorry that the account system has something wrong on Sat when you use it, and we have already fixed the issue later that day. So could you please go to your App Store account to reinstall the app for a try again? It should be ok now.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0